Rivetweb Installation

Rivetweb requires Apache HTTP Webserver 2.2 with Apache Rivet >= 2.0.1. It is also recommended you use Tcl >= 8.5 with Rivet as current implementation of hidden data structures relies heavily on Tcl's dict command. Current implementation of some of Rivetweb components also exploits tdom to manipulate XML and XHTML code.

As of today Rivetweb hasn't released any artifact, so you if you want to test it you have to clone the code from the git repository

git clone git://git.code.sf.net/p/rivetweb/code rivetweb

Rivetweb is still very unstable and under active development. You can have new updates of your code by pulling them from repository

cd <path-to-rivetweb-dir>
git pull

See the documentation of your OS to install the Apache HTTP Server, Tcl, tdom and git.